* フロッピー版Vine 5.0インストーラ [#n8551fe1]
 CD/DVDブートやPXEブートが出来ず、フロッピーディスクからしかブート出来ないPCには、フロッピーインストーラがあると便利です。そこで、[[Fedora Core Floppy Installer:http://www.thisiscool.com/fcfloppy.htm]]にあるFedora Core 5向けのフロッピーディスクのインストーラのイメージを改造して、Vine 5.0向けのフロッピーインストラーのイメージを作成しました。tar.gzで固めて、下のリンクに添付しました。イメージファイルが8個になり、フロッピーへの書き込みが大変ですが。イメージをフロッピーディスクに書き込み、1枚目から起動して、フロッピーディスクを入れ替えると、テキストベースのインストーラが起動します。なお、1枚目のフロッピーディスクは書き込み可能にしておかないとダメです。また、古いPCでインストールがうまくいかない場合、電源管理ACPIをサポートしていないと考えられるので、1枚目のフロッピーディスク内のvine.batファイルを開き、
 CD/DVDブートやPXEブートが出来ず、フロッピーディスクからしかブート出来ないPCには、フロッピーインストーラがあると便利です。そこで、[[Fedora Core Floppy Installer:http://www.thisiscool.com/fcfloppy.htm]]にあるFedora Core 5向けのフロッピーディスクのインストーラのイメージを改造して、Vine 5.0向けのフロッピーインストーラのイメージを作成しました。tar.gzで固めて、下のリンクに添付しました。イメージファイルが8個になり、フロッピーへの書き込みが大変ですが。イメージをフロッピーディスクに書き込み、1枚目から起動して、フロッピーディスクを入れ替えると、テキストベースのインストーラが起動します。なお、1枚目のフロッピーディスクは書き込み可能にしておかないとダメです。また、古いPCでインストールがうまくいかない場合、電源管理ACPIをサポートしていないと考えられるので、1枚目のフロッピーディスク内のvine.batファイルを開き、

> loadlin vmlinuz initrd=initrd.img

を

> loadlin vmlinuz noacpi acpi=off initrd=initrd.img

に書き換えるとインストールがうまくいくと思います。FTP経由でインストールする際は、

> サイト名 : ftp.ring.gr.jp
> Linuxディレクトリ : /pub/linux/Vine/Vine-5.0/i386

と指定するといいです。なお、/pub/linux/Vine/Vine-5/i386/Vine/base以下のファイルの情報と、パッケージ配置の情報に食い違いがあるためなのか、インストール中に、多数のパッケージについて、

> 「パッケージxxxが開けません。原因はおそらく、ファイルの欠落、またはパッケージの破損です。(以下省略)」

というエラーメッセージが出ます。しかし、Enterキーを連打すれば、インストールが続けられ、エラーが出たパッケージはダウンロード、インストールされるようですし、インストール後、Vine Linuxが正常に起動します。問題があるようなら、フロッピーインストーラを再作成します。

> フロッピーインストーラ [[vine-5.0-fi.tar.gz:http://sarl-tokyo.com/files/Vine/floppy-installer/5.0/vine-5.0-fi.tar.gz]]、 [[md5sum.txt:http://sarl-tokyo.com/files/Vine/floppy-installer/5.0/vine-5.0-fi.md5sum.txt]]

インストーラについてコメントがありましたら、[[2009年8月27日の日記:http://sarl-tokyo.com/diary/?date=20090827]]のページでツッコミをして下さい。

トップ   編集 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS